最新消息:欢迎大家加入浏览迷千人QQ群:189904973 反馈与交流,还可以关注浏览迷微信公众号:iliulanmi 随时调戏。 吐血推荐:浏览器内核检测 / 浏览器测试工具 / Chrome下载 / 大马路导航

jQuery 2.0不再支持IE6/7/8

关注浏览器 浏览迷 14501 浏览 8 评论

JQuery 2.0的发布象征着jQuery JavaScript库到了一个重要里程碑。2.0版本比前任版本在大小上缩减了12%,但是更值得注意的是,jQuery 2.0不再对IE6/7/8三个版本进行支持

jQuery 2.0不再支持IE6/7/8

七年前jQuery的诞生,开始让开发者更简单的操作HTML和编写JavaScript,jQuery的跨浏览器特性,更是很快受到了广大开发者的青睐。根据去年的一项调查显示,粗略估计,网络上一半的站点都在使用jQuery。

停止对旧版IE的支持,是否会改变jQuery的使用率?答案也许是不会。如果你的网站需要维护对IE8或者低版本(或者是IE9和IE10在兼容模式下运行),你只需要沿用jQuery1.9或者以下版本

“jQuery2.0主要用于现代网络,”jQuery的Dave Methvin在Query Foundation网站上写道,“我们有jQuery1.x版本处理旧版浏览器,并且期望他可以支持好几年。”

如果你想要同时兼容新旧版浏览器,你可以使用条件注释,让2.0在新浏览器上使用,而旧版本使用1.9,但是更简单的方法则是沿用jQuery1.x版本。至少目前2.0的主要用例,对IE的支持是不再考虑范围内了,而是Chrome或者Firefox的附加组件,PhoneGap应用程序或是node.js。

转载请注明:浏览迷 » jQuery 2.0不再支持IE6/7/8

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

网友最新评论 (8)

  1. 沙个发
    欧阳宣8年前 (2013-05-24)回复 Maxthon 4.1.0.600 Maxthon 4.1.0.600 Windows 8 x64 Edition Windows 8 x64 Edition
  2. 地板!
    浏览迷8年前 (2013-05-24)回复 Google Chrome 28.0.1500.20 Google Chrome 28.0.1500.20 Windows 8 x64 Edition Windows 8 x64 Edition
  3. 8年前 (2013-05-24)回复 Safari 6.0 Safari 6.0 iPhone iOS 6.1.2 iPhone iOS 6.1.2
  4. 关键还得看QQ支持哪些系统…… :lol:
    潍坊万达广场8年前 (2013-05-24)回复 Google Chrome 26.0.1410.64 Google Chrome 26.0.1410.64 Windows 8 x64 Edition Windows 8 x64 Edition
  5. :razz: 我快被IE8 折腾疯了 。。说是要用新技术,结果领导就喜欢用IE6 ,让IE6支持HTML5真是有难度 ← ← 死活赖着终于升级IE8了 ╮(╯▽╰)╭ 结果各种CSS样式无效
    继续打酱油8年前 (2013-05-24)回复 Firefox 11.0 Firefox 11.0 Windows 7 Windows 7
    • @继续打酱油:装个chrome框架即可
      路过8年前 (2013-05-24)回复 Google Chrome 29.0.1516.3 Google Chrome 29.0.1516.3 Windows 8 x64 Edition Windows 8 x64 Edition
  6. 早就应该不支持这些古董了
    i8年前 (2013-05-25)回复 Firefox 21.0 Firefox 21.0 GNU/Linux x64 GNU/Linux x64
  7. 好无压力
    文科8年前 (2013-05-27)回复 Firefox 24.0 Firefox 24.0 Windows 7 x64 Edition Windows 7 x64 Edition